We’re here to help

Mac OS X Mavericks won't download Avira latest is there a work around? Will not be updating the OS

Completed

Comments

1 comment

  • Official comment
    Avatar
    Arthur Lukas Huptas

    Hello Kim,

    Well, there sadly no workaround as macOS Mavericks isn't supported for a while now. Our Avira for Mac app needs at least macOS 10.11 El Capitan to work. Sure, due to security reasons we strongly recommend to use the most updated version of macOS if possible.

    Best,

    Arthur Lukas Huptas

    Avira Community Manager

    Comment actions Permalink

Please sign in to leave a comment.